Can't compile trem 1.3

Hi there.
I have a problem with compiling of trem 1.3 source code

What I did:

  • Modified some texts
  • Modified sound paths to custom one

these are yet at the moment.

I am compiling the game on linux (Ubuntu) more exactly WSL. Installed mingw package to compile so used mingw g++ (tried with gcc either) and added the EXPORT path to mingw g++. Of course used Makefile with ‘make’ command.

I had some missing headers file: mman.h , pwd.h , wait.h.
After that i get these errors: trem compile error -

What causing? i have a fresh installed wsl ubuntu with mingw package.

Thanks for help

1 Like

Maybe solved? Tried compile on Arch Linux (native not wsl), and compiled succesfully…Gonna try with mingw later As well


Keep us posted on the status of this issue.

1 Like

with GNU compiler i can compile it to x86_64 but with mingw cant. same log on pastebin

1 Like

I’ve used ubuntu on WSL to compile this source code perfectly. Try running “sudo apt-get update” and then the script I have at to install all necessary dependencies, then run “make PLATFORM=mingw32” to compile it.