Error: Configstring > MAX_CONFIGSTRINGS (happening again...)

So i got this error a while back on the test server. And was told it was my HUD. well i connected to grangerpub today and guess what…

Is there any way to fix this without having to remove or disable my HUD. I’m assuming an update was added recently because like i said above ive never had this issue before on grangerpub just the test server. I’m not willing to play without my hud, so until this is fixed i guess i will not be playing tremulous. If anyone could help me fix this issue i would greatly appreciate it. Im currently using Volts HUD 2.0 Final.

a few things i need you to try!

can you /condump right after you attempt to connect.

also, can you go to the mods on the main menu and load “slacker”, and then tell me the value of cg_hudFiles?

I really wish grangerhub was all in base folder. its annoying me in so many ways

Well either another updated was added since i posted this or the server is just being weird. but i had no problems connecting this time when i tried again.

I’m pretty sure its a server side bug, Effect. I’m not sure what to do about it.

We can’t do that Spamo, we’d end up breaking people’s clients for non-pure servers with our multiprotocol stuff.

Well. Sometimes there are different bugs. Like my settings reset randomly on grangerhub for some reason. and is fkin with my autogens o.O

lol yea its done that a few times to me. might start backing up certain files to be safe

this is happening to me right now :frowning:

Haven’t had the autogen bug yet, but it isn’t really a problem for me anyway. You should probably do what I did, all of my important settings are saved in a few cfgs (tremfusion team binds cvars yay) and if the autogen ever fucks up I’ll just have to /exec setup.

Also I know of this forum existence because I tried to log on GrangerPub server in Trem, and couldn’t enter in the game because of a maxconfigstrings error or something like that. As I searched on google for help, I saw a link to this website. Halp please?

Ooh! I’ve had same problem!

I know, that’s why I moved your post here ;).

Yea I know :smiley:

Also Hi Spark! :stuck_out_tongue:

what hud are you using?

I believe this is both server and client side issue. I believe this message is in regards to the serverinfo string which is sent to the client on initial connect.

The problem is, that the string is “too-big”- this string is going to contain various Cvar’s as well as information regarding each player connected (including they’re names with color codes).

[[ I’m probably getting some of this info wrong, as some is sent initially and there is also updates periodically for the client to choose the correct “model”, whether all this is sent on connect (prior too “has entered the game” is yet to be determined. ]]

As-is, ioquake3 and tremulous both use fixed size buffers for this cruft; and most of it is just that, cruft. Clients don’t need all the cvars listed in “serverinfo” (which has become bloated in tremulous); and of the information that is sent, not all of it was ever fully implemented.

  1. Servers should send less info.
  2. Clients should be capable of processing at-least 1400bytes at a time. May also need to handle fragments, though shouldn’t be problem.

To give you an idea of what I’m talking about, connect to grangerhub. Execute “/configstrings”. You can see, for example that cvars for suddenDeath time, and the QVM version info (slacker …[yadayada] lakitu…); which are never used inside the client, except to be listed in the “serverinfo” menu from the browser menu.


Also, my client MAXCONFIGSTRING is 1024 bytes. I believe this is typical for most if not all tremulous clients. I have not checked GPP.

I have the same problem

This is happening to me now. Usually it will happen once and ill try to reconnect and i can enter. But now im unable to join because its giving me this error almost everytime. Sometimes there are different errors

Did you take note of which maps were on the server at the time, and how many players were online?