GPP/Tremfusion Console Issue

As a few people may know I have been experiencing issues with opening the console in GPP and Tremfusion. In this topic I will go over exactly what I have done.

Firstly, I deleted all Tremulous files off my computer, App Data files, gone.

Secondly, downloaded Tremulous 1.1.0 straight off the site, installed it in the directory of C:Program Files\Tremulous (Windows 7)

Followed by installing Tremulous GPP in the same directory.

From there I opened Tremulous-GPP.exe, this sent me to the main menu.

I try to use the console with the key “~” or ’ but nothing worked. I joined servers to do the same, nothing worked.

I checked ALL autogen.cfg files, the console key is set correctly to ~ or `
I have tried changing it, didn’t make a difference.

Not quite sure if it is a flaw in the download or a mistake I am making, but I cannot see it.
I’m leaning towards my mistake because I have tried Tremfusion with 1.1.0 client and same results came up, no console.

Any thoughts or advice is appreciated.

Here is a raw part of my autogen.cfg

// generated by tremfusion, do not modify
bind TAB "+scores"
bind ENTER "+button2"
bind ESCAPE "togglemenu"
bind SPACE "+moveup"
bind + "sizeup"
bind - "sizedown"
bind = "sizeup"
bind [ "weapprev"
bind \ "+mlook"
bind ] "weapnext"
bind _ "sizedown"
bind ` "toggleconsole"
bind a "+moveleft"
bind b "buy ammo"
bind c "+movedown"
bind d "+moveright"
bind e "deconstruct"
bind f "+button3"
bind h "scoresUp"
bind i "messagemode4"
bind m "itemact medkit"
bind n "scoresDown"
bind q "+button7"
bind r "reload"
bind s "+back"
bind t "messagemode"
bind u "messagemode3"
bind w "+forward"
bind x "boost"
bind y "messagemode2"
bind z "+zoom"
bind ~ "toggleconsole"
bind PAUSE "pause"
bind UPARROW "+forward"
bind DOWNARROW "+back"
bind LEFTARROW "+left"
bind RIGHTARROW "+right"
bind ALT "+strafe"
bind CTRL "+attack"
bind SHIFT "+speed"
bind DEL "+lookdown"
bind PGDN "+lookup"
bind END "centerview"
bind F1 "vote yes"
bind F2 "vote no"
bind F11 "screenshotJPEG"
bind MOUSE1 "+attack"
bind MOUSE2 "+button5"
bind MOUSE3 "+button2"
bind MWHEELDOWN "weapnext"
bind MWHEELUP "weapprev"
seta cg_fuelInfoScale "0.5"
seta cg_fuelInfoY "150"
seta cg_fuelInfoX "0"
seta cg_chatTeamPrefix "1"
seta voice "default"
seta cg_noTaunt "0"
seta cg_smoothClients "0"
seta com_blood "1"
seta cg_projectileNudge "1"
seta cg_optimizePrediction "1"
seta cg_spectatorConfig ""
seta cg_humanConfig ""
seta cg_alienConfig ""
seta cg_hudFilesEnable "0"
seta cg_binaryShaderScreenScale "1.0"
seta cg_rangeMarkerBuildableTypes "support"
seta cg_rangeMarkerForBlueprint "1"
seta cg_rangeMarkerLineThickness "4.0"
seta cg_rangeMarkerLineOpacity "0.4"
seta cg_rangeMarkerSurfaceOpacity "0.08"
seta cg_rangeMarkerDrawFrontline "1"
seta cg_rangeMarkerDrawIntersection "1"
seta cg_rangeMarkerDrawSurface "1"
seta cg_tutorial "1"
seta cg_disableScannerPlane "0"
seta cg_disableCommandDialogs "0"
seta cg_disableBuildDialogs "0"
seta cg_disableUpgradeDialogs "0"
seta cg_disableWarningDialogs "1"
seta cg_lightFlare "3"
seta cg_consoleLatency "3000"
seta cg_bounceParticles "0"
seta cg_depthSortParticles "1"
seta cg_flySpeed "600"
seta cg_unlagged "1"
seta cg_sprintToggle "0"
seta cg_stickySpec "1"
seta cg_disableBlueprintErrors "1"
seta cg_wwToggle "1"
seta cg_wwFollow "1"
seta cg_wwSmoothTime "300"
seta cg_noVoiceText "0"
seta cg_noVoiceChats "0"
seta cg_noPrintDuplicate "0"
seta cg_teamChatsOnly "0"
seta teamoverlay "1"
seta cg_teamOverlayMaxPlayers "8"
seta cg_teamOverlaySortMode "1"
seta cg_drawTeamOverlay "1"
seta cg_staticDeathCam "0"
seta cg_thirdPersonShoulderViewMode "1"
seta cg_thirdPersonRange "75"
seta cg_runroll "0.005"
seta cg_runpitch "0.002"
seta cg_teslaTrailTime "250"
seta cg_maxSpeedTimeWindow "2000"
seta cg_drawSpeed "0"
seta cg_lagometer "0"
seta cg_crosshairSize "1"
seta cg_drawChargeBar "1"
seta cg_drawSnapshot "0"
seta cg_drawDemoState "1"
seta cg_drawFPS "1"
seta cg_drawClock "0"
seta cg_drawTimer "1"
seta cg_draw2D "1"
seta cg_drawGun "1"
seta ui_chatCommands "1"
seta cg_emoticons "1"
seta ui_developer "0"
seta ui_textWrapCache "1"
seta ui_lastServerRefresh_3_time ""
seta ui_lastServerRefresh_2_time "1450650107"
seta ui_lastServerRefresh_1_time ""
seta ui_lastServerRefresh_0_time ""
seta ui_selectedMap "0"
seta cg_shadows "1"
seta cg_stereoSeparation "0"
seta cg_viewsize "100"
seta ui_ffa_fraglimit "20"
seta ui_ffa_timelimit "0"
seta ui_tourney_fraglimit "0"
seta ui_tourney_timelimit "15"
seta ui_team_fraglimit "0"
seta ui_team_timelimit "20"
seta ui_team_friendly "1"
seta ui_ctf_capturelimit "8"
seta ui_ctf_timelimit "30"
seta ui_ctf_friendly "0"
seta g_spScores1 ""
seta g_spScores2 ""
seta g_spScores3 ""
seta g_spScores4 ""
seta g_spScores5 ""
seta g_spAwards ""
seta g_spVideos ""
seta g_spSkill "2"
seta ui_browserMaster "0"
seta ui_browserGameType "0"
seta ui_browserSortKey "4"
seta ui_browserShowFull "1"
seta ui_browserShowEmpty "0"
seta cg_brassTime "2500"
seta cg_drawCrosshair "4"
seta cg_drawCrosshairNames "1"
seta cg_marks "1"
seta server1 ""
seta server2 ""
seta server3 ""
seta server4 ""
seta server5 ""
seta server6 ""
seta server7 ""
seta server8 ""
seta server9 ""
seta server10 ""
seta server11 ""
seta server12 ""
seta server13 ""
seta server14 ""
seta server15 ""
seta server16 ""
seta ui_teamName "Pagans"
seta ui_opponentName "Stroggs"
seta ui_redteam "Pagans"
seta ui_blueteam "Stroggs"
seta ui_dedicated "0"
seta ui_gametype "3"
seta ui_joinGametype "0"
seta ui_netGametype "3"
seta ui_actualNetGametype "3"
seta ui_redteam1 "0"
seta ui_redteam2 "0"
seta ui_redteam3 "0"
seta ui_redteam4 "0"
seta ui_redteam5 "0"
seta ui_blueteam1 "0"
seta ui_blueteam2 "0"
seta ui_blueteam3 "0"
seta ui_blueteam4 "0"
seta ui_blueteam5 "0"
seta ui_netSource "2"
seta ui_menuFiles "ui/menus.txt"
seta ui_currentTier "0"
seta ui_currentMap "0"
seta ui_currentNetMap "0"
seta ui_mapIndex "0"
seta ui_currentOpponent "0"
seta cg_selectedPlayer "0"
seta cg_selectedPlayerName ""
seta ui_lastServerRefresh_0 "Dec-21, 2015 at 9:20"
seta ui_lastServerRefresh_1 ""
seta ui_lastServerRefresh_2 "Dec-21, 2015 at 9:21"
seta ui_lastServerRefresh_3 "Dec-21, 2015 at 9:20"
seta ui_scoreAccuracy "0%"
seta ui_scoreImpressives "0"
seta ui_scoreExcellents "0"
seta ui_scoreCaptures "0"
seta ui_scoreDefends "0"
seta ui_scoreAssists "0"
seta ui_scoreGauntlets "0"
seta ui_scoreScore "0"
seta ui_scorePerfect "0"
seta ui_scoreTeam "0 to 0"
seta ui_scoreBase "0"
seta ui_scoreTime "00:00"
seta ui_scoreTimeBonus "0"
seta ui_scoreSkillBonus "0"
seta ui_scoreShutoutBonus "0"
seta ui_smallFont "0.2"
seta ui_bigFont "0.5"
seta ui_findPlayer "Sarge"
seta ui_q3model "0"
seta cg_hudFiles "ui/hud.txt"
seta ui_recordSPDemo "0"
seta ui_teamArenaFirstRun "1"
seta g_warmup "20"
seta capturelimit "8"
seta ui_serverStatusTimeOut "7000"
seta cg_autoswitch "1"
seta sv_rconLog ""
seta sv_dlURL ""
seta sv_wwwBaseURL ""
seta sv_master2 ""
seta sv_master3 ""
seta sv_master4 ""
seta sv_master5 ""
seta cl_timedemoLog ""
seta cl_clantag ""
seta cl_dlURLOverride ""
seta cl_demoConfig ""
seta cl_humanConfig ""
seta cl_alienConfig ""
seta cl_spectatorConfig ""
seta cl_consoleFont ""
seta net_socksServer ""
seta net_socksUsername ""
seta net_socksPassword ""

Thank you for your time.


i have the same issue (but on linux) when i accidentally change keyboard language for trem. then ~ button doesn’t open console. maybe you have defined some key combination that switches between keyboard languages and you hit it accidentally

1 Like

I have done literally nothing.

Console key works fine for 1.1.0

Have you tried shift+esc?
I believe that is the backup combination to brining up the console by default

1 Like

Yes I have tried it, doesn’t work.

"cg_consoleLatency “3000"”
what’s that I wonder. Mine is set to 3000 as well, but check just in case that this isn’t effecting your console. There might be a bug where this actually works on your system and delays the console pull-down in seconds or something like that.

However I still don’t believe that’s what the variable is for since there’s this command-variable for the gpp client I use specifically:
set scr_conspeed “3”
basically that is the speed which the console gets pulled down. It may not be available in default gpp because I believe this is a SEGFAULT-GPP/Tremfusion client specific variables.

1 Like