Issues and bugs regarding Tremulous bots

Bots are meant to start with a Construction Kit on a certain occasion:

When a nearby structure has equal to or less than 50% of it’s maximum health.

I might as well just post this here:

Firing after an enemy went behind a wall, continues following path while firing:

Bot is not firing at enemies:

Bots do not buy helmets (in warmup):

P.S. Sparky, I have been thinking about the Fortress map, and I will remove the unnecessary nodes along the wall.


Those are interesting approaches to bot building to consider @avarthar :slight_smile: ! As a side question, does anyone know if any previous Tremulous mod at least attempted to have build bots?

Currently in the swirl game mode, we have the ckit provided as a side arm, so humans always have them like the blaster. However in the vanilla game mode (basically 1.1 vanilla) and in the chocolate game mode (gpp vanilla) the ckit takes up the primary weapon slot. The bot system is currently being worked on the chocolate game mode, and once the major issues are worked out, I’ll be merging the system up to vanilla and swirl. At the moment I only have the bots spawn as a ckit if there is a builable damaged nearby the predicted spawn node, and there is an arm nearby.


Bots use Blaster instead of Rifle (in actual game)

1 Like

@dGr8LookinSparky Nope, no bots system ever had bots that was able to build the way you want them to.

I’ve went in-game and here’s what I managed to see so far:

  1. The bots end up looking for a node (They switch between the nodes they can see a little too fast for what is really needed.) behind them or possibly through the wall. (The range of which they search they can see nodes at might be a little too big. I had this problem on Ambush when putting it too high.)
  2. There is obviously an error happening when bots try to repair and another bot repairs before them. (The action which they try to do won’t change fast enough leading them going on the same path for a short-while and may end up in a corner where they can’t reach a new node possibly giving them no NEW actions to do. (They are still stuck in REPAIR mode possibly.))
  3. From what I can see, quite a few problems might be caused by an overflow of commands/actions to be done at the same time. (If there’s an enemy when they repair they switch so fast that they can’t repair nor kill any enemies.

A possible fix to a lot of those bugs. Priorities. (For example, if there’s an enemy, what’s the point in repairing if he’s gonna kill the bot or kill the building afterwards anyway? etc…)

For now that’s only what I saw. I’ll try to test them back a little more in the following days. (@StarlightGlimmer sent me the password so I can take a look into it.)


After testing some more.
Here are what I found so far.

  1. The bots seem to not aim Up or Down when targeting the path nodes. It only rotates towards it, but doesn’t target it per say. Meaning it might have trouble getting into it. Maybe having a small sub-local temp pathing system or a node connected to the bot’s model that would detect if there is an obstacle so it goes back on a better path. (I was watching aliens on Narrow_Edge when it happened. But I doubt humans will be any different since it’s the same system for both. Mini-update. I watched humans as well, it happens too.)

  2. The bots also end up going in loops sometimes. Maybe the node path randomizing might be too random or not enough.

Those are the only problems I could find tonight. I will try to find more tomorrow.


Ok so here we see a poor helpless bot trying to escape the pit

Train operator realized hes locked out

meeting ended, back to work



:quakethonk: Isn’t this just related to the bots Sparky is working on for 1.3?


The title just says tremulous bots, therefore that isn’t 100% true ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

1 Like

Although I’m indeed happy that you got Zombies to work, I have to agree that this thread was created mostly for the bot system Sparky’s working on.

Putting Zombies’ mod in a proper thread would probably be better and less misleading.

Anyway, Congratulations on getting Zombies to work ^^


Oh mine? I’m still hopelessly stuck on that

Besides, the download is helplessly broken