Problems starting 1.12 and 1.13

My Apple keyboard problem is solved and now I have to ask you for your support the second time.

I´m running Tremulous 1.3.0 alpha 0.12 and was not able to start a game since this morning.
I get the same result with 1.3.0. alpha 0.13

After a double klick (see screenshot) the program crashes and show me directly my regular screen.


Apple Mac Pro 5.1
X5690 6 core
32 GB Ram
OS: latest update of High Sierra 10.13.3

Any Ideas or hints what could be wrong with my system wich was running perfect up to this morning ?

Everything else is running like a charm, the only exception is Tremulous :frowning:


Thank you for reporting this issue @Locutus :slight_smile: . I’m not familiar with Macs (@blowFish is our macOS developer), but I do have some basic questions. Since the last time you could connect to a server, did your operating system and/or drivers update? Have you recently installed any new programs? Have you recently changed anything with your Tremulous setup/folders?

It can be helpful if you were to post here the crash report which could be found in your tremulous homepath directory (to find that, enter into your Tremulous console, while you have your client open, /fs_homepath , it may be in a hidden folder, so you would have to enable show hidden files which I know can be a bit tricky to figure out on macOS LMGTFY - Let Me Google That For You ). Once in your Tremulous homepath directory, the crash report might be right there, or in might be in the gpp folder, or it might be in the trem_1-3_alpha001 folder. Where it might be, it would have crash in the name.

[color=yellow]Note: Before posting any crash report or console dump, make sure that you remove/censor any information that could be a concern for privacy, like your IP addresses, and computer user name that could show in path names.[/color]

There is a bug with all trem clients currently where if you have a lot of pk3 files, that could exceed the memory allotted to the client and cause a crash. If that is the issue you are having, I recommend that you go to your Tremulous homepath directory (see above for how to do that), and delete the pk3 files inside the following folders: base , trem_1-3_alpha001 , and unitremia_0002.

Tomorrow I will be looking into merging pk3 files on Unitremia and GrangerLab, and creating a new fs_game for both, as a work around for players who don’t clean up their pk3 downloads. But ultimately the way dependencies are handled in the filesystem does need to be fixed so that that kind of issue doesn’t occur, but that might have to wait for what comes after 1.3, if it would break backwards compatibility.


Do you mean the game crashes and returns you to the desktop or it just returns you to the main menu?

In both case, I would suggest that the problem might be from the files the server makes the client download.
For some reason tremulous has a hard time making sure the file has been sent correctly. (Or at least this happened to me in the past and way too often to be ignored in my opinion :slight_smile: )

Something I might suggest as actions to try when it happens:

  1. Try to see on another completely clean client if it connects. (Yes sv_allowdownload and such are needed.)
  2. If the older client works, go to the directory where your tremulous downloads the servers data. (Usually it is in %appdata%/tremulous on windows. (I’m not sure where it is on OS X sadly. :frowning: I still did not try looking into it on my imac. It might be somewhere like Applications/Tremulous or something like that.))
  3. Make a backup of the server’s downloaded data. (It will probably only be a single file that was either corrupted by the connection either failing or just tremulous having trouble.)
  4. Once you have made a backup of the server data, you can delete the old one so the tremulous folder is clean and has to redownload the server’s data.
  5. Reopen your game and try joining the server again for the data to download.

If that did not work, you might want to try making a new and clean install of tremulous and applying the 1.3 client files back.

If reinstalling tremulous did not work either, well sadly I am not yet used enough with tremulous crashes to help you further.


If the issue is with the number of downloaded .pk3 files (which I suspect could be the case), or any corrupted downloaded .pk3 file, reinstalling trem won’t help with that issue, as those files would still be in the Tremulous homepath. The best way to address that issue (if it is that issue), is to follow the procedure I recommended in my previous post in this thread, which is basically to just go directly to the tremulous homepath folder, and remove the excess .pk3 files.


Don’t connect to the [GPP] or [1.1] listing of servers in the browser (for multiptotocol servers). Connect to the one without gpp or 1.1 after the name.


That should not be a problem. I usually connect to the [GPP] taged listings (so that I have the same GUID as with my old gpp client if I ever want to use it).


@Locutus , I changed the mod directory on both the GrangerLab server and the Unitremia server. Let me know if you still have issues connecting to either.