Tremulous 1.3 alpha is not working :(

After I downloaded and extracted to Tremulous root folder, open it, and it’s nothing response. I tried to end program in Task Manager, re-open it and still not working for me. :frowning:

Anybody have solutions yet?

Did you try to wait for some minutes ? It has to initialize it’s packages on first launch.


Had been waited for minutes, still nothing happens. :confounded:

Well, stick to 1.1 then.
1.3 alpha is more like a pre-pre-alpha and the client is kinda buggy.
Stick to tremfusion for now.

really, u should just be more patient. Tremulous is generating an RSA keypair (for the purposes of client identification). to verify that this is actually what’s going on, run Tremulous in a console, and check whether Tremulous seems to hang upon the following message:

on some operating systems (ie. Linux), generating secure random data can take a long time. in an attempt to speed things up, do something on ur computer with ur mouse&keyboard, such as: post on the forum, watch pr0n, etc.

that’s a fact, but the key generation part is not a bug.

maybe Tremulous should generate cryptographic keys in the background, while the main menu is displayed;1 until generation is finished, don’t allow the user to create or join any server, and advize him/her against exiting the game before key generation finishes. or, failing this approach, Tremulous could throw up a dialog notifying the user of the key generation process.2

1 this sounds perfect, because a user could personalize settings during this, which is an input-intensive procedure.
2 this is also desired because most users don’t run the game in a terminal.


Better yet, an actual visual representation of the task’s progression to begin with.


ind33d, and the cryptography library of choice, nettle, has the capability to report progress !

however, from the security point of view, the more detailed the progress bar is, the more information it leaks, unless there’s some fakery involved; but i guess this is neligible.

You’re right. :slight_smile:

Well anyways, @dGr8LookinSparky said if I opened 1.3 alpha for first time, don’t close it. You need to wait at least 5 minutes (Because 1.3 alpha had new assets and will giving update with those old version). Both my desktop and laptop PC are currently worked.

Problem solved.

1 Like

Well, downloading the new assets is a part of the bootstrapping process, but a majority of that bootstrap time is generating RSA keys.

1 Like

Yup. Just like qkey file for 1.1 or GPP version.