Map release: Tremulous Gameplay Sandbox #1

A testing map for different gameplay layouts.
Therefore textures and brushwork are very basic.
Suggestions are welcome. :+1:



Important notes:

  • You can like it or not but please respect artistic freedom.

-initial release
-jet pack fix
-layout changes
-light changes
-texture bug fixed
exchanged all textures, new set copyright 2016 by Matth


you will have higher chances of constructive feedback if you paste screenshots. downloading, installing, testing is time-consuming for ppl who don’t do it on a daily basis

I need feedback of ppl who actually played this map.

I’ve downloaded the map, got to modify something in it, don’t know why, but yea…
The file name send an error when loading it in-game.
/map tgs01_v1.0
Couldn’t find maps/tgs01_v1.0.bsp

Changed the file name to tgs01 and it worked… Don’t know why, maybe I just miss-spelled the name when writing it.

I’ll play it and give you a feedback.

1 Like

Nice thx.
The map name is ‘tgs01’ so that might be the problem.
I think best results will come when sparky uploaded the map to ghub so stay tuned :slight_smile:


I’ve already loaded the map and found a problem.

When choosing a team. No choices appear. (same with classes.)

Had to type:
/team aliens
/class level0

(Which is not to be expected on a map :wink: )

The alien spawn:
Maybe a wall could be better than a hole with a block_path event.

The in-game mistake screenshots:
Wall 01 Missing:

Wall 02 Missing also:

The join team and select a class mistake:

Right now it’s kinda hard to play the map, due to the fact that few of the basic requirements are missing.
It is playable with the commands. But you don’t want to have to type, /team aliens, /class level0, /team humans, /class rifler and such commands.

That’s the most far I’ve been right now in your map. The map itself is ok, but few things are missing or mistaken. (Like the map name on the file :wink: which needs to be changed when we want to load it. )

Those problems are related to your tremulous binaries and not to the map itself.
This is caused by pk3 files and various mods loaded together etc. Try it it with a cleaned up base / tmp.base dir.

The ‘missing’ texture is the skybox. So its supposed to be like that.
The file name is ‘map-tgs01_v1.0’ wich shows the correct map name in between ‘tgs01’.
Thats standard…

I use tremfusion and my trem is clean. I didn’t use any mod or such on it.
Used /map tgs01_v1.0 and didn’t worked.
I renamed it to tgs01 and it worked.

and when I was in-game it showed what I showed you in the pictures.

ehm again: the .bsp file name is important. its /map tgs01 OR /devmap tgs01 .
Another example:
so in this case: /map karith
Also u might use the menu / create server. It should be listed in the map list 'Tremulous Gameplay Sandbox

Yes i saw your screenshots but didn’t saw any errors that are related to the map. Maps CAN’T change stuff like your menu except files are included in the pk3 that can do this and thats not the case. Thats weird :confused: Ever tried another map?

It’s the only map that does that to me. All the other ones works great and I got thousands of maps…

Tried it with the normal gpp client?

No, I ain’t a gpp player, I use tremfusion 1.1.

How about the 1.1.0 client?

Tremfusion and the default 1.1.0 client don’t change that much.
It dosn’t alter the maps at all.

In that case i don’t know what the problem is. I’m very sure its not related to the map… hmm

It might not be, but I’ll try later on a clean trem 1.1 default client.

1 Like

Reminds me of Valve’s map editor. Interesting.

I need to check it out later.

1 Like

Those textures are from the valve SDK.
I do hammer maps also btw :wink:

I just tried the map on the new client, and it works fine for me so far. I don’t have that team joining menu error. @avarthar , I’ve seen an error like that before when the cgame doesn’t match the game modules, or when there are conflicts in multiple pk3 files. It could be a problem related to your installation, or some extra pk3 files you already have, but I don’t think the map is directly related to that problem.

In any case I’ll this map uploaded to the test7341 server shortly so that we can try it out at the dev games tonoight (which has already started btw).

yea, I’ll try on another client to be sure